<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml"
      xmlns:fb="http://www.facebook.com/2008/fbml"
      xmlns:og="http://ogp.me/ns#"
      lang="en-us">
    <head>

    

    

      <script>
        var mp_global = {"subsection": null, "fb_app_id": "210638399128904", "tag": ["headline", "Granite City High School", "Civic Memorial High School", "Marquette Catholic High School", "Alton High School"], "instance": "advantagenews", "type": "article", "section": "sports", "urlname": "an-eye-on-sports-march-13-2020", "author": []};
      </script>
      
      
      <title>An Eye on Sports: March 13, 2020 - AdVantageNEWS.com</title>
      <meta name="generator" content="Metro Publisher (www.metropublisher.com)" />
      <meta name="viewport" content="width=device-width, initial-scale=1" />
      <meta itemprop="name" id="publisher-name" content="AdVantage News - News. Sports. Local. - Everybody gets it!" />
      
        <script type="text/javascript">var _mp_require = {"baseUrl": "https:\/\/d2az0yupc2akbm.cloudfront.net\/vanguardistas.publicview\/4.164.post34.dev572495354778\/static\/", "config": {"js\/page_roundup_location": null, "js\/page_content": {"is_pro": false, "related_links_url": "https:\/\/advantagenews.com\/api\/content\/7e51320c-624e-11ea-bb53-1244d5f7c7c6\/get_related_links", "osm_active": true, "media_gallery": {"slideshowStart": "Start Slideshow", "wh_sizes": [320, 480, 720, 1080, 1280, 1440, 1920], "slideshowStop": "Stop Slideshow", "slideshowCurrent": "{current} of {total}"}, "show_dynamic_map": false, "back_title": "Return to \"An Eye on Sports: March 13, 2020\"", "ctype": null, "comments_url": "https:\/\/advantagenews.com\/api\/content\/7e51320c-624e-11ea-bb53-1244d5f7c7c6\/get_comments", "tcomments": {"submit": "Submit", "email_invalid": "Invalid email address", "fb_app_id": "210638399128904", "fb_login": " or login with Facebook", "content_uuid": "7e51320c-624e-11ea-bb53-1244d5f7c7c6", "rss_feed": "Comment Feed", "type_comment": "Type your comment here...", "fb_logout": "Logout", "comment_required": "Comment required", "ugc_email_for_comments": true, "ugc_allow_comments": true, "type_captchas": "Enter the word from the Image", "view_more": "View More", "name_required": "Name required", "post_success": "Comment successfully submitted. All comments are moderated and generally will be posted if they are on-topic and not abusive.", "wrong_captchas": "Wrong Captchas", "email": "Email", "comments": "Comments", "info_text": "All comments are moderated and generally will be posted if they are on-topic and not abusive.", "chars_left": "characters left", "subject_required": "Subject required", "post_to_wall": "Publish comment to your Wall", "post_moderated": "Comment successfully submitted. All comments are moderated and generally will be posted if they are on-topic and not abusive.", "your_name": "Your Name", "subject": "Type subject here...", "email_required": "Email required"}, "google_api_key": null, "show_occ_paginator": false, "media_support": {"wh_sizes": [320, 480, 720, 1080, 1280, 1440, 1920], "slots": [{"display_type": "gallery", "media_count": 6, "slot_ord": 0, "slot_id": 33214, "slot_uuid": "5895e56f-15c9-4885-d71d-ddfc5cc74d28"}]}}, "js\/page_roundup_content": null}, "paths": {"facebook": "\/\/connect.facebook.net\/en_US\/sdk"}, "shim": {"facebook": {"exports": "FB"}}};</script>
<script
  id="requirejs"
  src="https://d3t13abgv0q40.cloudfront.net/mp-public/js/require-jquery.bbdcab34b563441ac2b91d548bf4ab20.js"></script>
<script>
  require = _mp_require;
  requirejs = _mp_requirejs;
  define = _mp_define;
</script>

        
      
      <meta name="description" content="A photographic recap of the week in prep athletics."/>
      <meta name="keywords" content="headline,Granite City High School,Civic Memorial High School,Marquette Catholic High School,Alton High School"/>
      <link rel="manifest" href="/manifest.json">
      
      <meta name="thumbnail" content="https://advantagenews.com/downloads/40482/download/Donovan%20Clay%20EYE%203-13-20.jpg?cb=7bb19da313fd0184c2dc44aa73b149c9&amp;w=1200"/>
      <link rel="canonical" href="https://advantagenews.com/sports/an-eye-on-sports-march-13-2020/"/>

      <link href="https://advantagenews.com/api/rss/content.rss" rel="alternate" type="application/rss+xml" title="An Eye on Sports: March 13, 2020 - AdVantageNEWS.com" />
      <link href="https://advantagenews.com/api/rss/flipboard.rss" rel="alternate" type="application/rss+xml" title="An Eye on Sports: March 13, 2020 - AdVantageNEWS.com" />

      <link rel="stylesheet" type="text/css" href="https://d3t13abgv0q40.cloudfront.net/mp-public/css/theme-clean.4d48ce3c5d38f5f557fdccdf165a40c2.css"/>
      <link rel="stylesheet" type="text/css" href="https://advantagenews.com/api/design-2243174a77d1dc54abf7c84c9d64b6fc/screen.css"/>
      
      <script src="https://d3t13abgv0q40.cloudfront.net/mp-public/js/mp.d17656d3fb93453f37bef20c72e8a1c9.js" async="true"></script>
      <link rel="shortcut icon" href="https://advantagenews.com/api/design-2243174a77d1dc54abf7c84c9d64b6fc/CheckMark.png"/>

      <!-- Google Analytics -->
<script>
window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
ga('create', 'UA-50643402-1', 'auto');
ga('require', 'displayfeatures');
ga('send', 'pageview');
</script>
<script async src='https://www.google-analytics.com/analytics.js'></script>
<!-- End Google Analytics -->
      <script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>

<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];



(function() {
  var resizeTimer;
  var windowwidth = window.innerWidth;
  function resizer() {
      googletag.pubads().refresh();
  }

  window.addEventListener("resize", function(){ 
      if (window.innerWidth != windowwidth) {
          windowwidth = window.innerWidth;
          clearTimeout(resizeTimer);
          resizeTimer = setTimeout(resizer, 250);
      }
  });
})();


googletag.cmd.push(function() {
  var target_keys = ['tag', 'type', 'instance', 'section', 'subsection', 'urlname', 'author'],
        i;
  for (i = 0; i < target_keys.length; i++) {
      googletag.pubads().setTargeting(target_keys[i], mp_global[target_keys[i]]);
  }

  var billboard_mapping = googletag.sizeMapping().
addSize([0, 0], []).
addSize([970, 250], [970, 250]).
build();

var mpu_mapping = googletag.sizeMapping().
addSize([0, 0], [[300, 250], [300, 600]]).
build();

var leaderboard_mapping = googletag.sizeMapping().
addSize([0, 0], [[320, 50], [300, 50]]).
addSize([750, 200], [728, 90]).
addSize([1050, 250], [[970, 90], [970, 250]]).
build();

var wallpaper_right_mapping = googletag.sizeMapping().
addSize([0, 0], []).
addSize([1000, 0], [160, 600]).
build();

var wallpaper_left_mapping = googletag.sizeMapping().
addSize([0, 0], []).
addSize([1000, 0], [160, 600]).
build();


  
  
  googletag.defineSlot('422578608/mp_leaderboard_bottom', [728, 90], 'leaderboard_bottom').defineSizeMapping(leaderboard_mapping).addService(googletag.pubads());
  googletag.defineSlot('422578608/mp_leaderboard_top', [728, 90], 'leaderboard_top').defineSizeMapping(leaderboard_mapping).addService(googletag.pubads());
  googletag.defineSlot('422578608/mp_leaderboard_nav', [728, 90], 'leaderboard_nav').defineSizeMapping(leaderboard_mapping).addService(googletag.pubads());

  googletag.defineSlot('422578608/mp_mpu_bb_99', [728, 90], '9ad56ee4-65d6-11ea-b5b2-1244765d23cd').defineSizeMapping(mpu_mapping).addService(googletag.pubads());
googletag.defineSlot('422578608/mp_mpu_bb_99', [728, 90], '9ad5fa58-65d6-11ea-b5b2-1244765d23cd').defineSizeMapping(mpu_mapping).addService(googletag.pubads());
googletag.defineSlot('422578608/mp_mpu_bb_99', [728, 90], '9ad67f78-65d6-11ea-b5b2-1244765d23cd').defineSizeMapping(mpu_mapping).addService(googletag.pubads());
googletag.defineSlot('422578608/mp_mpu_bb_99', [728, 90], '9ad705f6-65d6-11ea-b5b2-1244765d23cd').defineSizeMapping(mpu_mapping).addService(googletag.pubads());
googletag.defineSlot('422578608/mp_mpu_bb_99', [728, 90], '9ad79732-65d6-11ea-b5b2-1244765d23cd').defineSizeMapping(mpu_mapping).addService(googletag.pubads());
googletag.defineSlot('422578608/mp_mpu_bb_99', [728, 90], '9ad82058-65d6-11ea-b5b2-1244765d23cd').defineSizeMapping(mpu_mapping).addService(googletag.pubads());

  

  googletag.pubads().collapseEmptyDivs(true);
  googletag.enableServices();


  var last_refresh = Date.now();
  document.addEventListener('refresh_ads', function () {
    if (Date.now() - last_refresh > 1000) {
        last_refresh = Date.now();
        googletag.pubads().refresh();
    }
  });


});
</script>

      <meta property="og:image" content="https://advantagenews.com/downloads/40482/download/Donovan%20Clay%20EYE%203-13-20.jpg?cb=7bb19da313fd0184c2dc44aa73b149c9&amp;w=1200"/><meta property="og:image:width" content="565"/><meta property="og:image:height" content="425"/><meta property="og:image" content="https://advantagenews.com/downloads/40486/download/Noah%20Turbyfill%20EYE%203-13-20.jpg?cb=7f4f0c7bbd01b40ce37fcd5c10e822c8&amp;w=1200"/><meta property="og:image:width" content="565"/><meta property="og:image:height" content="425"/><meta property="og:image" content="https://advantagenews.com/downloads/40485/download/Ky%27%20Lun%20Rivers%20EYE%203-13-20.jpg?cb=0c066312e015ae8170ee7464157d9ad5&amp;w=1200"/><meta property="og:image:width" content="425"/><meta property="og:image:height" content="565"/><meta property="og:image" content="https://advantagenews.com/downloads/40481/download/Brett%20Terry%20EYE%203-13-20.jpg?cb=b36e7626ee6463f3f27b0625129bd709&amp;w=1200"/><meta property="og:image:width" content="565"/><meta property="og:image:height" content="425"/><meta property="og:image" content="https://advantagenews.com/downloads/40483/download/Iggy%20McGee%20EYE%203-13-20.jpg?cb=bf7195af61677ffb5fef08eb5e1cfc67&amp;w=1200"/><meta property="og:image:width" content="425"/><meta property="og:image:height" content="565"/><meta property="og:image" content="https://advantagenews.com/downloads/40484/download/Jahkeis%20Tippett%20EYE%203-13-20.jpg?cb=69218014399ca9cfde2be5ad7230fcce&amp;w=1200"/><meta property="og:image:width" content="565"/><meta property="og:image:height" content="425"/><meta property="og:type" content="article"/><meta property="og:title" content="An Eye on Sports: March 13, 2020"/><meta property="og:description" content="A photographic recap of the week in prep athletics."/><meta property="og:url" content="https://advantagenews.com/api/content/7e51320c-624e-11ea-bb53-1244d5f7c7c6/"/><meta property="og:site_name" content="AdVantageNEWS.com"/><meta property="fb:app_id" content="210638399128904"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@newsadvantage"/><meta name="twitter:creator" content="@newsadvantage"/><meta name="twitter:image" content="https://advantagenews.com/downloads/40482/download/Donovan%20Clay%20EYE%203-13-20.jpg?cb=7bb19da313fd0184c2dc44aa73b149c9&amp;amp;w=1200"/>
      <meta name="author" content=""/><meta property="article:tag" content="headline"/><meta property="article:tag" content="Granite City High School"/><meta property="article:tag" content="Civic Memorial High School"/><meta property="article:tag" content="Marquette Catholic High School"/><meta property="article:tag" content="Alton High School"/><meta property="article:published_time" content="2020-03-14T03:00:00"/>
      
      <script type="application/ld+json">
{"@graph": [{"name": "An Eye on Sports: March 13, 2020", "image": "https://advantagenews.com/downloads/40482/download/Donovan%20Clay%20EYE%203-13-20.jpg?cb=7bb19da313fd0184c2dc44aa73b149c9&w=565", "thumbnailUrl": "https://advantagenews.com/downloads/40482/download/Donovan%20Clay%20EYE%203-13-20.jpg?cb=7bb19da313fd0184c2dc44aa73b149c9&w=565", "headline": "An Eye on Sports: March 13, 2020", "mainEntityOfPage": "https://advantagenews.com/sports/an-eye-on-sports-march-13-2020/", "articleSection": "Sports", "@type": "Article", "datePublished": "2020-03-14T03:00:00", "keywords": ["headline", "Granite City High School", "Civic Memorial High School", "Marquette Catholic High School", "Alton High School"], "publisher": {"name": "AdVantageNEWS.com", "logo": {"@type": "ImageObject", "url": "https://advantagenews.com/api/design-2243174a77d1dc54abf7c84c9d64b6fc/advantage_logo_webheader.png"}, "@type": "Organization"}, "url": "https://advantagenews.com/sports/an-eye-on-sports-march-13-2020/", "@id": "https://advantagenews.com/sports/an-eye-on-sports-march-13-2020/", "dateModified": "2020-03-09T16:39:50.610317", "author": {"name": "AdVantageNEWS.com", "@type": "Organization"}}], "@context": "http://schema.org"}
</script>

      
      <link rel="apple-touch-icon" href="https://advantagenews.com/api/design-2243174a77d1dc54abf7c84c9d64b6fc/CheckMark.png" />
      

      

      

      
      
      <meta name="google-site-verification" content="ZuYQbm_lfma2tXEX0Iph28RNM-JZLHTMTJ1mq-kXAdI" />








<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-50643402-1', 'advantagenews.com');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');

</script>

<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#property=589c85a2de1d780011959cdb&product=inline-share-buttons' async='async'></script>

<div id="fb-root"></div>
<script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.3&appId=210638399128904&autoLogAppEvents=1"></script>

<!-- Begin Sumo Me Embed Code -->
<script src="//load.sumome.com/"data-sumo-site-id="2d2e7c892216deaea652b244203be8c476f74b71509bed9e4364b4e04e0b5c89"async></script>
<!-- Begin Sumo Me Embed Code -->


<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=210638399128904";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>


      
 <style type="text/css">
 @font-face {
    font-family: 'Museo500';
    src: url('Museo500-Regular-webfont.eot');
    src: url('Museo500-Regular-webfont.eot?#iefix') format('embedded-opentype'),
         url('Museo500-Regular-webfont.woff') format('woff'),
         url('Museo500-Regular-webfont.ttf') format('truetype'),
         url('Museo500-Regular-webfont.svg#Museo500') format('svg');
    font-weight: normal;
    font-style: normal;
}
h1,h2,h3,h4   { font-family: 'Museo500', Helvetica, Arial, sans-serif; font-weight: 100}
/*
h1,h2,h3,h4,body,h2 a:link
 { font-family: 'StMarieThin', Helvetica, Arial, sans-serif; font-weight: 100; font-size: 1.2em;
background-image: url('https://advantagenews-admin.metropublisher.com/designcenter/23/Screen%20Shot%202014-01-26%20at%204.39.06%20PM.png');
background-repeat: no-repeat;
background-position-x: -9px;
padding-left: 30px;
}
*/

#topnav .mainnav {
    background: none repeat scroll 0 0 #000000;
}

#topnav .mainnav a:hover {
    background-image: none;
    background-color: #E50312;
}

/* Drop down Navigation */
#topnav .subnav, #bottomnav .subnav_nested {
    display: none;
}

nav ul .subnav_nested {
    display: block;
    opacity: 0;
    z-index: 500;
}

.subnav_nested {
   position: absolute;
   margin: 0;
   border: 0;
   list-style: none;
   white-space: normal;
   width: auto; z-index: 3000
   }
#topnav .subnav_nested li {
   margin: 0;
   padding:0;
   border: 0;
   overflow: hidden;
   float: none;
   display: block; }

.mainnav ul {
    position: absolute;
    opacity: 1;
    -webkit-transition: opacity .25s ease .1s;
    -moz-transition: opacity .25s ease .1s;
    -o-transition: opacity .25s ease .1s;
    -ms-transition: opacity .25s ease .1s;
    transition: opacity .25s ease .1s;
}

.mainnav li:hover > ul {
   opacity: 1;
   }

.mainnav ul li {
    height: 0;
    overflow: hidden;
    padding: 0;
    -webkit-transition: height .25s ease .1s;
    -moz-transition: height .25s ease .1s;
    -o-transition: height .25s ease .1s;
    -ms-transition: height .25s ease .1s;
    transition: height .25s ease .1s;
}

.mainnav li:hover > .subnav_nested li {
    height: 100%;
    overflow: visible;
    padding: 0;
}

.mainnav .subnav_nested li a {
    margin: 0;
    border: none;
}
   #main.fullwidth {width: calc(100% - 4.5em)}
   @media only screen and (max-width:32em) {
   .tools { display: block }
   #fb-top .fb_iframe_widget_fluid span, .fb_iframe_widget_fluid span iframe {width: 300px !important }}
   
.mp-event-item .mp-credits,
.mp-list-item .mp-credits,
.event_thumb .credits { display: none }
</style>
        
        
        

        <script type="text/javascript">
          /* register service worker to enable PWA */
          if ('serviceWorker' in navigator) {
            window.addEventListener('load', function() {
              navigator.serviceWorker.register('/mp-service-worker.js').then(function(registration) {
                // Registration was successful
                console.log('ServiceWorker registration successful with scope: ', registration.scope);
              }, function(err) {
                // registration failed :(
                console.log('ServiceWorker registration failed: ', err);
              });
            });
          }
        </script>

        

      <meta id="worstRating" itemprop="worstRating" content="0" />
      <meta id="bestRating" itemprop="bestRating" content="5" />
      <meta name="theme-color" content="#ED1D23"/>
    </head>
  <body class="mp-type-article mp-sidebar">
      

    <div id="body">
    <a class="skip-to-main" href="#maincontent">Skip to main content</a>
    <div id="wallpaper_left">
 <script type="text/javascript">
     googletag.cmd.push(function() { googletag.display('wallpaper_left'); });
 </script>
</div>

    
      
        <div id="section_sports">
          <div id="subsection_website">
      <div id="page">




        <div id="top">
          <div id="topads">

            <div id="topad1">
              <div id="leaderboard_top">
 <script type="text/javascript">
     googletag.cmd.push(function() { googletag.display('leaderboard_top'); });
 </script>
</div>

            </div>

            

          </div>
          
<div id="logo">
  
  <div id="mp-search-bar">
    <form action="https://advantagenews.com/api/search.html">
      <input type="text" name="q" title="Enter Search Words" placeholder="Search..." />
      <button class="search submit" type="submit" name="sa">Search</button>
    </form>
  </div>
  <div class="logo">
  <!--div class="header_links" tal:condition="python: header_links or socialmedia_urls"-->
    <div class="header_links">
        
            <a href="https://advantagenews.com/contact-us">Contact Us</a>
        
            <a href="https://advantagenews.com/advertise">Advertise</a>
        
            <a href="https://www.advertiserportal.com/advantagenews/" target="_blank">Bill Pay</a>
        
    </div>
    
  <a rel="home" href="https://advantagenews.com" title="AdVantageNEWS.com"><img src="https://advantagenews.com/api/design-2243174a77d1dc54abf7c84c9d64b6fc/advantage_logo_webheader.png" class="standard" alt="AdVantageNEWS.com" title="AdVantageNEWS.com" />
    <meta id="logo-url" itemprop="url" content="https://advantagenews.com/api/design-2243174a77d1dc54abf7c84c9d64b6fc/advantage_logo_webheader.png" />
    <meta id="logo-width" itemprop="width" content="728" />
    <meta id="logo-height" itemprop="height" content="250" />
    <meta id="publisher-logo" itemprop="logo" itemscope="" itemtype="http://schema.org/ImageObject"
        itemref="logo-url logo-width logo-height" />
                                                                       <img src="https://advantagenews.com/api/design-2243174a77d1dc54abf7c84c9d64b6fc/advantage_logo_webheader.png" class="responsive" alt="AdVantageNEWS.com" title="AdVantageNEWS.com" /></a>
</div>

</div>

<nav id="topnav">
  <a href="#" class="pull">Menu</a>
  
<ul class="mainnav">
  <li class="menu_section_start menu_section_news">
	<a href="https://advantagenews.com/news">News<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_news__1">
        <a href="http://advantagenews.com/news">News</a>
      </li>
      <li class="menu_subsection_crime">
        <a href="https://advantagenews.com/news/crime">Crime</a>
      </li>
      <li class="menu_subsection_business">
        <a href="https://advantagenews.com/news/business">Business</a>
      </li>
      <li class="menu_subsection_end menu_subsection_election-questionnaire">
        <a href="http://advantagenews.com/election">Election questionnaire</a>
      </li>
    </ul>
  </li>
  <li class="selected menu_section_sports">
	<a href="https://advantagenews.com/sports">Sports<span class="nav_handle open"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_sports">
        <a href="http://advantagenews.com/sports">Sports</a>
      </li>
      <li class="menu_subsection_end menu_subsection_team-spotlight">
        <a href="https://advantagenews.com/sports/team-spotlight">Team Spotlight</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_obituaries">
	<a href="https://advantagenews.com/obituaries">Obits<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_end menu_subsection_obituaries__1">
        <a href="http://advantagenews.com/obituaries">Obituaries</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_features">
	<a href="https://advantagenews.com/features">Features<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_spotlight">
        <a href="https://advantagenews.com/features/spotlight">Spotlight</a>
      </li>
      <li class="menu_subsection_arts-entertainment">
        <a href="https://advantagenews.com/features/arts-entertainment">Arts &amp; entertainment</a>
      </li>
      <li class="menu_subsection_commentary">
        <a href="https://advantagenews.com/features/commentary">Commentary</a>
      </li>
      <li class="menu_subsection_announcements">
        <a href="https://advantagenews.com/features/announcements">Announcements</a>
      </li>
      <li class="menu_subsection_births">
        <a href="https://advantagenews.com/features/births">Births</a>
      </li>
      <li class="menu_subsection_recipes">
        <a href="http://advantagenews.com/recipes">Recipes</a>
      </li>
      <li class="menu_subsection_religion">
        <a href="https://advantagenews.com/features/religion">Religion</a>
      </li>
      <li class="menu_subsection_end menu_subsection_puzzles">
        <a href="http://advantagenews.com/features/puzzle-feed">Puzzles</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_contribute">
	<a href="http://advantagenews.com/suggestion-box">Contribute<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_suggestion-box">
        <a href="http://advantagenews.com/suggestion-box">Suggestions</a>
      </li>
      <li class="menu_subsection_story">
        <a href="http://advantagenews.com/submit-news">Submit a news tip</a>
      </li>
      <li class="menu_subsection_sports">
        <a href="http://advantagenews.com/submit-sports">Submit a sports tip</a>
      </li>
      <li class="menu_subsection_letter">
        <a href="http://advantagenews.com/submit-letter">Submit a letter to the editor</a>
      </li>
      <li class="menu_subsection_event">
        <a href="http://advantagenews.com/events/submit.html">Submit a calendar event</a>
      </li>
      <li class="menu_subsection_obituary-information">
        <a href="https://advantagenews.com/downloads/11459/download/Obituaries.pdf">Obituary information</a>
      </li>
      <li class="menu_subsection_birth-announcement-form">
        <a href="https://form.jotform.co/40084055095855" target="_blank">Birth announcement form</a>
      </li>
      <li class="menu_subsection_anniversary-form">
        <a href="http://form.jotformpro.com/form/40084456173958" target="_blank">Anniversary announcement form</a>
      </li>
      <li class="menu_subsection_engagement-announcement-form">
        <a href="http://form.jotformpro.com/form/40085146212949" target="_blank">Engagement announcement form</a>
      </li>
      <li class="menu_subsection_end menu_subsection_wedding-announcement-form">
        <a href="http://form.jotformpro.com/form/40085340856959" target="_blank">Wedding announcement form</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_contests">
	<a href="http://advantagenews.com/sportstrivia">Contests<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_sportstrivia">
        <a href="http://advantagenews.com/sportstrivia">Riverbend Sports Trivia answer</a>
      </li>
      <li class="menu_subsection_granite-city-sports-trivia">
        <a href="http://advantagenews.com/granite-city-sports-trivia-answer">Granite City Sports Trivia answer</a>
      </li>
      <li class="menu_subsection_readers-choice-riverbend-results">
        <a href="http://advantagenews.com/contests/readers-choice-results">Readers' Choice Riverbend results</a>
      </li>
      <li class="menu_subsection_end menu_subsection_readers-choice-results-gc">
        <a href="http://advantagenews.com/readers-choice-results-gc">Readers' Choice Granite City results</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_calendar">
	<a href="http://advantagenews.com/search/event/event-calendar/#page=1">Calendar<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_submit-events">
        <a href="http://advantagenews.com/events/submit.html">Submit a calendar event</a>
      </li>
      <li class="menu_subsection_end menu_subsection_garage-sales">
        <a href="https://easyclassads.com/classifieds?category=79-garage-sales" target="_blank">Garage sales</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_advertise">
	<a href="https://www.advantagereach.com/" target="_blank">Advertise<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_classified">
        <a href="https://easyclassads.com/" target="_blank">Classifieds</a>
      </li>
      <li class="menu_subsection_business-advertising">
        <a href="http://www.advantagereach.com/" target="_blank">Business advertising</a>
      </li>
      <li class="menu_subsection_garage-sales">
        <a href="https://easyclassads.com/classifieds?category=79-garage-sales" target="_blank">Garage sales</a>
      </li>
      <li class="menu_subsection_novena-ad">
        <a href="https://form.jotform.com/42505808903960" target="_blank">Novena ad</a>
      </li>
      <li class="menu_subsection_celebration-ad">
        <a href="https://form.jotform.com/61876706833971" target="_blank">Celebration ad</a>
      </li>
      <li class="menu_subsection_end menu_subsection_memorial-ad">
        <a href="https://form.jotform.com/42574704228961" target="_blank">Memorial ad</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_end menu_section_about">
	<a href="/about/about">About<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_contact-us">
        <a href="http://advantagenews.com/contact-us">Contact us</a>
      </li>
      <li class="menu_subsection_careers">
        <a href="https://form.jotform.com/73174229785163" target="_blank">Careers</a>
      </li>
      <li class="menu_subsection_archives">
        <a href="http://archive.advantagenews.com/" target="_blank">Archives</a>
      </li>
      <li class="menu_subsection_community-sponsorships">
        <a href="http://advantagenews.com/community-sponsorships">Community sponsorships</a>
      </li>
      <li class="menu_subsection_privacy-policy">
        <a href="http://advantagenews.com/about/privacy-policy">Privacy policy</a>
      </li>
      <li class="menu_subsection_end menu_subsection_about">
        <a href="http://advantagenews.com/about">About</a>
      </li>
    </ul>
  </li>
</ul>
<ul class="subnav">
  <li class="menu_subsection_start menu_subsection_sports">
    <a href="http://advantagenews.com/sports">Sports</a>
  </li>
  <li class="menu_subsection_end menu_subsection_team-spotlight">
    <a href="https://advantagenews.com/sports/team-spotlight">Team Spotlight</a>
  </li>
</ul>


</nav>


        </div>
        <div id="leaderboard_nav">
 <script type="text/javascript">
     googletag.cmd.push(function() { googletag.display('leaderboard_nav'); });
 </script>
</div>

        <div id="breadcrumbs"><a href="https://advantagenews.com">Home</a> <a href="https://advantagenews.com/sports">Sports</a> <a href="https://advantagenews.com/sports/an-eye-on-sports-march-13-2020/">An Eye on Sports: March 13, 2020</a></div>
        <main id="maincontent" role="main" tabindex="-1">

  
<div id="pagetype_article" itemscope="" itemtype="http://schema.org/Article" itemid="https://advantagenews.com/sports/an-eye-on-sports-march-13-2020/">

<span itemprop="image" itemscope="" itemtype="http://schema.org/ImageObject">
    <meta id="content-image-url" itemprop="url" content="https://advantagenews.com/downloads/40482/download/Donovan%20Clay%20EYE%203-13-20.jpg?cb=7bb19da313fd0184c2dc44aa73b149c9" />
    <meta id="content-image-width" itemprop="width" content="565" />
    <meta id="content-image-height" itemprop="height" content="425" />
</span>






  
  <article id="main">





<header>
  <div id="title">
            <link itemprop="mainEntityOfPage" href="https://advantagenews.com/sports/an-eye-on-sports-march-13-2020/" />
            <meta itemprop="name" content="An Eye on Sports: March 13, 2020" />
            <meta itemprop="description" content="A photographic recap of the week in prep athletics." />
            <meta itemprop="publisher"
                  itemscope=""
                  itemtype="http://schema.org/Organization"
                  itemref="publisher-name publisher-logo" />
            <meta itemprop="dateModified" content="2020-03-09T16:39:50.610317" />
            <h1 itemprop="headline">An Eye on Sports: March 13, 2020</h1>
            
            
                <meta itemprop="image" itemscope="" itemtype="http://schema.org/ImageObject"
                  itemref="content-image-url content-image-width content-image-height" />

                
            
          </div>
          
          <div id="pageinfos" class="pageinfos">
    
    <span style="display: none" itemprop="author" itemscope="" itemtype="http://schema.org/Organization" content=""><meta itemprop="name" content="AdVantage News - News. Sports. Local. - Everybody gets it!" /></span>
    <time itemprop="datePublished" datetime="2020-03-14T03:00:00">
    <p class="date">March 14, 2020</p>
    <p class="time">3:00 AM</p></time>
</div>

</header>


<div id="backlink_container" style="display:none"><a href="" id="backlink">Back to Search Results</a></div>
<aside class="tools">
    <div id="fb-top" data-show_like="True" data-show_share="True" data-like_url="https://advantagenews.com/api/content/7e51320c-624e-11ea-bb53-1244d5f7c7c6/" data-size="small" data-layout="standard" data-action="like" data-show_faces="True"></div>
    
    <div class="share"><a class="RSS_link" href="https://advantagenews.com/sports/index.rss">RSS</a></div>
    <div class="share"><a class="print" href="#" onclick="javascript: window.print(); return false;" target="_self">Print</a></div>

</aside>



    

    <div id="content" class="carousel content no_js" data-transition="content" data-loop="false" itemprop="articleBody">


     <div>

    <div id="media-carousel-33214" class="media-gallery">  <div class="gallery_slide " id="media-thumb-33214-1">    <div class="gallery_item group33214" id="ms_33214-0" data-slot-media-path="/api/slot_media/47396/" data-slot_type="file"><img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="Donovan Clay EYE 3-13-20.jpg" data-src="https://advantagenews.com/downloads/40482/download/Donovan%20Clay%20EYE%203-13-20.jpg?cb=7bb19da313fd0184c2dc44aa73b149c9&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 320, 450, 565]" src="https://advantagenews.com/downloads/40482/download/Donovan%20Clay%20EYE%203-13-20.jpg?cb=7bb19da313fd0184c2dc44aa73b149c9" title="Donovan Clay EYE 3-13-20.jpg"><p class="credits">photo by Jeff Helmkamp</p>              </div>    </div>  <div class="gallery_slide " id="media-thumb-33214-2">    <div class="gallery_item group33214" id="ms_33214-1" data-slot-media-path="/api/slot_media/47397/" data-slot_type="file"><img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="Noah Turbyfill EYE 3-13-20.jpg" data-src="https://advantagenews.com/downloads/40486/download/Noah%20Turbyfill%20EYE%203-13-20.jpg?cb=7f4f0c7bbd01b40ce37fcd5c10e822c8&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 320, 450, 565]" src="https://advantagenews.com/downloads/40486/download/Noah%20Turbyfill%20EYE%203-13-20.jpg?cb=7f4f0c7bbd01b40ce37fcd5c10e822c8" title="Noah Turbyfill EYE 3-13-20.jpg"><p class="credits">photo by Dan Cruz</p>              </div>    </div>  <div class="gallery_slide " id="media-thumb-33214-3">    <div class="gallery_item group33214" id="ms_33214-2" data-slot-media-path="/api/slot_media/47398/" data-slot_type="file"><img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="Ky' Lun Rivers EYE 3-13-20.jpg" data-src="https://advantagenews.com/downloads/40485/download/Ky%27%20Lun%20Rivers%20EYE%203-13-20.jpg?cb=0c066312e015ae8170ee7464157d9ad5&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 320, 425]" src="https://advantagenews.com/downloads/40485/download/Ky%27%20Lun%20Rivers%20EYE%203-13-20.jpg?cb=0c066312e015ae8170ee7464157d9ad5" title="Ky' Lun Rivers EYE 3-13-20.jpg"><p class="credits">photo by Jeff Helmkamp</p>              </div>    </div>  <div class="gallery_slide " id="media-thumb-33214-4">    <div class="gallery_item group33214" id="ms_33214-3" data-slot-media-path="/api/slot_media/47399/" data-slot_type="file"><img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="Brett Terry EYE 3-13-20.jpg" data-src="https://advantagenews.com/downloads/40481/download/Brett%20Terry%20EYE%203-13-20.jpg?cb=b36e7626ee6463f3f27b0625129bd709&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 320, 450, 565]" src="https://advantagenews.com/downloads/40481/download/Brett%20Terry%20EYE%203-13-20.jpg?cb=b36e7626ee6463f3f27b0625129bd709" title="Brett Terry EYE 3-13-20.jpg"><p class="credits">photo by Theo Tate</p>              </div>    </div>  <div class="gallery_slide " id="media-thumb-33214-5">    <div class="gallery_item group33214" id="ms_33214-4" data-slot-media-path="/api/slot_media/47400/" data-slot_type="file"><img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="Iggy McGee EYE 3-13-20.jpg" data-src="https://advantagenews.com/downloads/40483/download/Iggy%20McGee%20EYE%203-13-20.jpg?cb=bf7195af61677ffb5fef08eb5e1cfc67&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 320, 425]" src="https://advantagenews.com/downloads/40483/download/Iggy%20McGee%20EYE%203-13-20.jpg?cb=bf7195af61677ffb5fef08eb5e1cfc67" title="Iggy McGee EYE 3-13-20.jpg"><p class="credits">photo by Theo Tate</p>              </div>    </div>  <div class="gallery_slide " id="media-thumb-33214-6">    <div class="gallery_item group33214" id="ms_33214-5" data-slot-media-path="/api/slot_media/47401/" data-slot_type="file"><img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="Jahkeis Tippett EYE 3-13-20.jpg" data-src="https://advantagenews.com/downloads/40484/download/Jahkeis%20Tippett%20EYE%203-13-20.jpg?cb=69218014399ca9cfde2be5ad7230fcce&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 320, 450, 565]" src="https://advantagenews.com/downloads/40484/download/Jahkeis%20Tippett%20EYE%203-13-20.jpg?cb=69218014399ca9cfde2be5ad7230fcce" title="Jahkeis Tippett EYE 3-13-20.jpg"><p class="credits">photo by Bill Roseberry</p>              </div>    </div></div><p class="lead"><strong>Follow AdVantage Sports on</strong> <a href="https://www.facebook.com/AdVSports/" target="_blank"><strong>Facebook</strong></a> <strong>and #AdVsports on</strong> <a href="https://twitter.com/search?q=#AdVsports&amp;src=tyah" target="_blank"><strong>Twitter</strong></a></p>&#13;&#13;&#13;


    
    

    </div>



    </div>


  



    
        
      
    



<aside class="tags">
<h4>Tags</h4>
                <a href="https://advantagenews.com/topics/headline/" rel="tag" >headline</a>

                <a href="https://advantagenews.com/topics/granite-city-high-school/" rel="tag" >Granite City High School</a>

                <a href="https://advantagenews.com/topics/civic-memorial-high-school/" rel="tag" >Civic Memorial High School</a>

                <a href="https://advantagenews.com/topics/marquette-catholic-high-school/" rel="tag" >Marquette Catholic High School</a>

                <a href="https://advantagenews.com/topics/alton-high-school/" rel="tag" >Alton High School</a>

</aside>


<aside id="bottompageinfos" class="pageinfos">
    
    
    <time datetime="2020-03-14T03:00:00">
    <p class="date">March 14, 2020</p>
    <p class="time">3:00 AM</p>
    </time>
</aside>



    

<aside id="related"></aside>


<div id="fb-comments"  data-comments_url="https://advantagenews.com/api/content/7e51320c-624e-11ea-bb53-1244d5f7c7c6/" data-num_posts="25"
      data-order_by="time"></div>
  </article>

  

  <aside id="side">
    

        

    <div class="mp-imgteaser"><a href="http://advantagenews.com/events/submit.html" title="Event submit promo"><img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="Event promo Gray" data-src="https://advantagenews.com/downloads/29951/download/Events%20Promo%20Black.jpg?cb=e1421b39a2fe3c910e50f6d509483c9b&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 300]" src="https://advantagenews.com/downloads/29951/download/Events%20Promo%20Black.jpg?cb=e1421b39a2fe3c910e50f6d509483c9b" title="Event promo Gray" /></a><p class="mp-credits"></p></div>
<div id="9ad56ee4-65d6-11ea-b5b2-1244765d23cd" class="mp-ad-sprocket ">
 <script type="text/javascript">
     googletag.cmd.push(function() {
        "use strict";
        var div_id = '9ad56ee4-65d6-11ea-b5b2-1244765d23cd';
        
        googletag.display('9ad56ee4-65d6-11ea-b5b2-1244765d23cd');
     });
 </script>
</div>
<div id="9ad5fa58-65d6-11ea-b5b2-1244765d23cd" class="mp-ad-sprocket ">
 <script type="text/javascript">
     googletag.cmd.push(function() {
        "use strict";
        var div_id = '9ad5fa58-65d6-11ea-b5b2-1244765d23cd';
        
        googletag.display('9ad5fa58-65d6-11ea-b5b2-1244765d23cd');
     });
 </script>
</div>
<div id="9ad67f78-65d6-11ea-b5b2-1244765d23cd" class="mp-ad-sprocket ">
 <script type="text/javascript">
     googletag.cmd.push(function() {
        "use strict";
        var div_id = '9ad67f78-65d6-11ea-b5b2-1244765d23cd';
        
        googletag.display('9ad67f78-65d6-11ea-b5b2-1244765d23cd');
     });
 </script>
</div>
<div class="mp-html">
  <!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/classic-081711.css" rel="stylesheet" type="text/css" />
<style type="text/css">#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif;  width:300px;}
	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="//advantagenews.us8.list-manage.com/subscribe/post?u=11bdf1530716b157d2889d11c&amp;id=3dda376f8a" class="validate" id="mc-embedded-subscribe-form" method="post" name="mc-embedded-subscribe-form" novalidate="" target="_blank">
<div id="mc_embed_signup_scroll">
<h3><strong><span style="font-family:Arial,Helvetica,sans-serif;">Local headlines&nbsp;in your email.</span></strong></h3>

<div class="mc-field-group"><label for="mce-EMAIL">Email Address </label> <input class="required email" id="mce-EMAIL" name="EMAIL" type="email" value="" /></div>

<div class="mc-field-group"><label for="mce-FNAME">First Name </label> <input id="mce-FNAME" name="FNAME" type="text" value="" /></div>

<div class="mc-field-group"><label for="mce-LNAME">Last Name </label> <input id="mce-LNAME" name="LNAME" type="text" value="" /></div>

<p>Powered by <a href="http://eepurl.com/Zphj9" title="MailChimp - email marketing made easy and fun">MailChimp</a></p>

<div class="clear" id="mce-responses">
<div class="response" id="mce-error-response" style="display:none"></div>

<div class="response" id="mce-success-response" style="display:none"></div>
</div>
<!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->

<div style="position: absolute; left: -5000px;"><input name="b_11bdf1530716b157d2889d11c_3dda376f8a" tabindex="-1" type="text" value="" /></div>

<div class="clear"><input class="button" id="mc-embedded-subscribe" name="subscribe" type="submit" value="Subscribe" /></div>
</div>
</form>
</div>
<!--End mc_embed_signup-->
</div>
<div class="mp-html">
  <p style="text-align: center;"><span style="font-size:16px;"><strong>Print editions:</strong></span><br />
<span style="font-size:14px;"><a href="http://archive.advantagenews.com/riverbend/" target="_blank" title="Page through Greater Alton"><span style="color: rgb(255, 0, 0);">Riverbend</span></a>&nbsp; &nbsp;|&nbsp; &nbsp;<a href="http://archive.advantagenews.com/granitecity/" target="_blank" title="Page through Granite City Edition"><span style="color: rgb(255, 0, 0);">Granite City</span></a></span><br />
<a href="http://archive.advantagenews.com/riverbend/" target="_blank"><img alt="This week's Greater Alton edition" src="http://archive.advantagenews.com/riverbend/riverbend.jpg" style="width: 95px; height: 109px;" /></a>&nbsp;<a href="http://archive.advantagenews.com/granitecity/" target="_blank"><img alt="This week's Granite City edition" src="http://archive.advantagenews.com/granitecity/granitecity.jpg" style="width: 95px; height: 109px;" /></a>&nbsp;</p>

<p style="text-align: center;"><span style="font-size:14px;"><a href="http://archive.advantagenews.com/jersey"><span style="color: rgb(255, 0, 0);">Jersey County</span></a>&nbsp; &nbsp;|&nbsp; &nbsp;<a href="http://archive.advantagenews.com/greene"><span style="color: rgb(255, 0, 0);">Greene County</span></a></span><br />
<a href="http://archive.advantagenews.com/jersey" target="_blank"><img alt="This week's Jersey County Shopper" src="http://archive.advantagenews.com/jersey/jcs.jpg" style="width: 95px; height: 145px;" /></a>&nbsp;<a href="http://archive.advantagenews.com/greene" target="_blank"><img alt="This week's Greene County Shopper" src="http://archive.advantagenews.com/greene/gcs.jpg" style="width: 95px; height: 145px;" /></a></p>

<p style="text-align: center;"><a href="http://archive.advantagenews.com" style="line-height: 1.6em;"><span style="color:#FF0000;">Back Issue Archives...</span></a></p>

<p style="text-align: center;"></p>

</div>
<div id="9ad705f6-65d6-11ea-b5b2-1244765d23cd" class="mp-ad-sprocket ">
 <script type="text/javascript">
     googletag.cmd.push(function() {
        "use strict";
        var div_id = '9ad705f6-65d6-11ea-b5b2-1244765d23cd';
        
        googletag.display('9ad705f6-65d6-11ea-b5b2-1244765d23cd');
     });
 </script>
</div>
<div id="9ad79732-65d6-11ea-b5b2-1244765d23cd" class="mp-ad-sprocket ">
 <script type="text/javascript">
     googletag.cmd.push(function() {
        "use strict";
        var div_id = '9ad79732-65d6-11ea-b5b2-1244765d23cd';
        
        googletag.display('9ad79732-65d6-11ea-b5b2-1244765d23cd');
     });
 </script>
</div>
<div id="9ad82058-65d6-11ea-b5b2-1244765d23cd" class="mp-ad-sprocket ">
 <script type="text/javascript">
     googletag.cmd.push(function() {
        "use strict";
        var div_id = '9ad82058-65d6-11ea-b5b2-1244765d23cd';
        
        googletag.display('9ad82058-65d6-11ea-b5b2-1244765d23cd');
     });
 </script>
</div>

    
  </aside>
  
  </div>


  


</main>

        <div id="bottom">
          <div id="bottomads">
            <div id="leaderboard_bottom">
 <script type="text/javascript">
     googletag.cmd.push(function() { googletag.display('leaderboard_bottom'); });
 </script>
</div>

          </div>
          
  
    <nav id="bottomnav">
      
<ul class="mainnav">
  <li class="menu_section_start menu_section_news">
	<a href="https://advantagenews.com/news">News<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_news__1">
        <a href="http://advantagenews.com/news">News</a>
      </li>
      <li class="menu_subsection_crime">
        <a href="https://advantagenews.com/news/crime">Crime</a>
      </li>
      <li class="menu_subsection_business">
        <a href="https://advantagenews.com/news/business">Business</a>
      </li>
      <li class="menu_subsection_end menu_subsection_election-questionnaire">
        <a href="http://advantagenews.com/election">Election questionnaire</a>
      </li>
    </ul>
  </li>
  <li class="selected menu_section_sports">
	<a href="https://advantagenews.com/sports">Sports<span class="nav_handle open"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_sports">
        <a href="http://advantagenews.com/sports">Sports</a>
      </li>
      <li class="menu_subsection_end menu_subsection_team-spotlight">
        <a href="https://advantagenews.com/sports/team-spotlight">Team Spotlight</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_obituaries">
	<a href="https://advantagenews.com/obituaries">Obits<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_end menu_subsection_obituaries__1">
        <a href="http://advantagenews.com/obituaries">Obituaries</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_features">
	<a href="https://advantagenews.com/features">Features<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_spotlight">
        <a href="https://advantagenews.com/features/spotlight">Spotlight</a>
      </li>
      <li class="menu_subsection_arts-entertainment">
        <a href="https://advantagenews.com/features/arts-entertainment">Arts &amp; entertainment</a>
      </li>
      <li class="menu_subsection_commentary">
        <a href="https://advantagenews.com/features/commentary">Commentary</a>
      </li>
      <li class="menu_subsection_announcements">
        <a href="https://advantagenews.com/features/announcements">Announcements</a>
      </li>
      <li class="menu_subsection_births">
        <a href="https://advantagenews.com/features/births">Births</a>
      </li>
      <li class="menu_subsection_recipes">
        <a href="http://advantagenews.com/recipes">Recipes</a>
      </li>
      <li class="menu_subsection_religion">
        <a href="https://advantagenews.com/features/religion">Religion</a>
      </li>
      <li class="menu_subsection_end menu_subsection_puzzles">
        <a href="http://advantagenews.com/features/puzzle-feed">Puzzles</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_contribute">
	<a href="http://advantagenews.com/suggestion-box">Contribute<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_suggestion-box">
        <a href="http://advantagenews.com/suggestion-box">Suggestions</a>
      </li>
      <li class="menu_subsection_story">
        <a href="http://advantagenews.com/submit-news">Submit a news tip</a>
      </li>
      <li class="menu_subsection_sports">
        <a href="http://advantagenews.com/submit-sports">Submit a sports tip</a>
      </li>
      <li class="menu_subsection_letter">
        <a href="http://advantagenews.com/submit-letter">Submit a letter to the editor</a>
      </li>
      <li class="menu_subsection_event">
        <a href="http://advantagenews.com/events/submit.html">Submit a calendar event</a>
      </li>
      <li class="menu_subsection_obituary-information">
        <a href="https://advantagenews.com/downloads/11459/download/Obituaries.pdf">Obituary information</a>
      </li>
      <li class="menu_subsection_birth-announcement-form">
        <a href="https://form.jotform.co/40084055095855" target="_blank">Birth announcement form</a>
      </li>
      <li class="menu_subsection_anniversary-form">
        <a href="http://form.jotformpro.com/form/40084456173958" target="_blank">Anniversary announcement form</a>
      </li>
      <li class="menu_subsection_engagement-announcement-form">
        <a href="http://form.jotformpro.com/form/40085146212949" target="_blank">Engagement announcement form</a>
      </li>
      <li class="menu_subsection_end menu_subsection_wedding-announcement-form">
        <a href="http://form.jotformpro.com/form/40085340856959" target="_blank">Wedding announcement form</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_contests">
	<a href="http://advantagenews.com/sportstrivia">Contests<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_sportstrivia">
        <a href="http://advantagenews.com/sportstrivia">Riverbend Sports Trivia answer</a>
      </li>
      <li class="menu_subsection_granite-city-sports-trivia">
        <a href="http://advantagenews.com/granite-city-sports-trivia-answer">Granite City Sports Trivia answer</a>
      </li>
      <li class="menu_subsection_readers-choice-riverbend-results">
        <a href="http://advantagenews.com/contests/readers-choice-results">Readers' Choice Riverbend results</a>
      </li>
      <li class="menu_subsection_end menu_subsection_readers-choice-results-gc">
        <a href="http://advantagenews.com/readers-choice-results-gc">Readers' Choice Granite City results</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_calendar">
	<a href="http://advantagenews.com/search/event/event-calendar/#page=1">Calendar<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_submit-events">
        <a href="http://advantagenews.com/events/submit.html">Submit a calendar event</a>
      </li>
      <li class="menu_subsection_end menu_subsection_garage-sales">
        <a href="https://easyclassads.com/classifieds?category=79-garage-sales" target="_blank">Garage sales</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_advertise">
	<a href="https://www.advantagereach.com/" target="_blank">Advertise<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_classified">
        <a href="https://easyclassads.com/" target="_blank">Classifieds</a>
      </li>
      <li class="menu_subsection_business-advertising">
        <a href="http://www.advantagereach.com/" target="_blank">Business advertising</a>
      </li>
      <li class="menu_subsection_garage-sales">
        <a href="https://easyclassads.com/classifieds?category=79-garage-sales" target="_blank">Garage sales</a>
      </li>
      <li class="menu_subsection_novena-ad">
        <a href="https://form.jotform.com/42505808903960" target="_blank">Novena ad</a>
      </li>
      <li class="menu_subsection_celebration-ad">
        <a href="https://form.jotform.com/61876706833971" target="_blank">Celebration ad</a>
      </li>
      <li class="menu_subsection_end menu_subsection_memorial-ad">
        <a href="https://form.jotform.com/42574704228961" target="_blank">Memorial ad</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_end menu_section_about">
	<a href="/about/about">About<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_contact-us">
        <a href="http://advantagenews.com/contact-us">Contact us</a>
      </li>
      <li class="menu_subsection_careers">
        <a href="https://form.jotform.com/73174229785163" target="_blank">Careers</a>
      </li>
      <li class="menu_subsection_archives">
        <a href="http://archive.advantagenews.com/" target="_blank">Archives</a>
      </li>
      <li class="menu_subsection_community-sponsorships">
        <a href="http://advantagenews.com/community-sponsorships">Community sponsorships</a>
      </li>
      <li class="menu_subsection_privacy-policy">
        <a href="http://advantagenews.com/about/privacy-policy">Privacy policy</a>
      </li>
      <li class="menu_subsection_end menu_subsection_about">
        <a href="http://advantagenews.com/about">About</a>
      </li>
    </ul>
  </li>
</ul>
<ul class="subnav">
  <li class="menu_subsection_start menu_subsection_sports">
    <a href="http://advantagenews.com/sports">Sports</a>
  </li>
  <li class="menu_subsection_end menu_subsection_team-spotlight">
    <a href="https://advantagenews.com/sports/team-spotlight">Team Spotlight</a>
  </li>
</ul>


    </nav>

    <div id="textnav">
      <ul>
  <li class="menu_section_start "
    >
    <a href="https://advantagenews.com/contact-us">Contact Us</a>
  </li>
  <li class=""
    >
    <a href="https://advantagenews.com/advertise">Advertise</a>
  </li>
  <li class="menu_section_end"
    >
    <a href="https://www.advertiserportal.com/advantagenews/" target="_blank">Bill Pay</a>
  </li>
</ul>

    </div>
  
  

  <div id="copyright">
    <p>AdVantage | 1000 W. Homer M. Adams Pkwy, Godfrey, IL 62035 | Phone: 618.463.0612 | Copyright 2018</p>
  </div>

  <div id="mp_credits">
    Built with <a href="https://www.metropublisher.com" target="new">Metro Publisher&#8482;</a>
  </div>




        </div>

      </div>
      </div>
      </div>
      
    
    <div id="wallpaper_right">
 <script type="text/javascript">
     googletag.cmd.push(function() { googletag.display('wallpaper_right'); });
 </script>
</div>

    </div>
  
  
  
  
    
  

    

    
      <script async defer src="//connect.facebook.net/en_US/sdk.js" ></script>
    

    

    <span id="mp-config" data-js="{&quot;_mp_page_content&quot;: {&quot;is_pro&quot;: false, &quot;related_links_url&quot;: &quot;https://advantagenews.com/api/content/7e51320c-624e-11ea-bb53-1244d5f7c7c6/get_related_links&quot;, &quot;osm_active&quot;: true, &quot;media_gallery&quot;: {&quot;slideshowStart&quot;: &quot;Start Slideshow&quot;, &quot;wh_sizes&quot;: [320, 480, 720, 1080, 1280, 1440, 1920], &quot;slideshowStop&quot;: &quot;Stop Slideshow&quot;, &quot;slideshowCurrent&quot;: &quot;{current} of {total}&quot;}, &quot;show_dynamic_map&quot;: false, &quot;back_title&quot;: &quot;Return to \&quot;An Eye on Sports: March 13, 2020\&quot;&quot;, &quot;ctype&quot;: null, &quot;comments_url&quot;: &quot;https://advantagenews.com/api/content/7e51320c-624e-11ea-bb53-1244d5f7c7c6/get_comments&quot;, &quot;tcomments&quot;: {&quot;submit&quot;: &quot;Submit&quot;, &quot;email_invalid&quot;: &quot;Invalid email address&quot;, &quot;fb_app_id&quot;: &quot;210638399128904&quot;, &quot;fb_login&quot;: &quot; or login with Facebook&quot;, &quot;content_uuid&quot;: &quot;7e51320c-624e-11ea-bb53-1244d5f7c7c6&quot;, &quot;rss_feed&quot;: &quot;Comment Feed&quot;, &quot;type_comment&quot;: &quot;Type your comment here...&quot;, &quot;fb_logout&quot;: &quot;Logout&quot;, &quot;comment_required&quot;: &quot;Comment required&quot;, &quot;ugc_email_for_comments&quot;: true, &quot;ugc_allow_comments&quot;: true, &quot;type_captchas&quot;: &quot;Enter the word from the Image&quot;, &quot;view_more&quot;: &quot;View More&quot;, &quot;name_required&quot;: &quot;Name required&quot;, &quot;post_success&quot;: &quot;Comment successfully submitted. All comments are moderated and generally will be posted if they are on-topic and not abusive.&quot;, &quot;wrong_captchas&quot;: &quot;Wrong Captchas&quot;, &quot;email&quot;: &quot;Email&quot;, &quot;comments&quot;: &quot;Comments&quot;, &quot;info_text&quot;: &quot;All comments are moderated and generally will be posted if they are on-topic and not abusive.&quot;, &quot;chars_left&quot;: &quot;characters left&quot;, &quot;subject_required&quot;: &quot;Subject required&quot;, &quot;post_to_wall&quot;: &quot;Publish comment to your Wall&quot;, &quot;post_moderated&quot;: &quot;Comment successfully submitted. All comments are moderated and generally will be posted if they are on-topic and not abusive.&quot;, &quot;your_name&quot;: &quot;Your Name&quot;, &quot;subject&quot;: &quot;Type subject here...&quot;, &quot;email_required&quot;: &quot;Email required&quot;}, &quot;google_api_key&quot;: null, &quot;show_occ_paginator&quot;: false, &quot;media_support&quot;: {&quot;wh_sizes&quot;: [320, 480, 720, 1080, 1280, 1440, 1920], &quot;slots&quot;: [{&quot;display_type&quot;: &quot;gallery&quot;, &quot;media_count&quot;: 6, &quot;slot_ord&quot;: 0, &quot;slot_id&quot;: 33214, &quot;slot_uuid&quot;: &quot;5895e56f-15c9-4885-d71d-ddfc5cc74d28&quot;}]}}, &quot;_mp_facebook_&quot;: true}"/><script async src="https://d3t13abgv0q40.cloudfront.net/mp-public/js/page_content.3b8e35a0389aced6827008c3100ef1ae.js" data-config="{&quot;is_pro&quot;: false, &quot;related_links_url&quot;: &quot;https://advantagenews.com/api/content/7e51320c-624e-11ea-bb53-1244d5f7c7c6/get_related_links&quot;, &quot;osm_active&quot;: true, &quot;media_gallery&quot;: {&quot;slideshowStart&quot;: &quot;Start Slideshow&quot;, &quot;wh_sizes&quot;: [320, 480, 720, 1080, 1280, 1440, 1920], &quot;slideshowStop&quot;: &quot;Stop Slideshow&quot;, &quot;slideshowCurrent&quot;: &quot;{current} of {total}&quot;}, &quot;show_dynamic_map&quot;: false, &quot;back_title&quot;: &quot;Return to \&quot;An Eye on Sports: March 13, 2020\&quot;&quot;, &quot;ctype&quot;: null, &quot;comments_url&quot;: &quot;https://advantagenews.com/api/content/7e51320c-624e-11ea-bb53-1244d5f7c7c6/get_comments&quot;, &quot;tcomments&quot;: {&quot;submit&quot;: &quot;Submit&quot;, &quot;email_invalid&quot;: &quot;Invalid email address&quot;, &quot;fb_app_id&quot;: &quot;210638399128904&quot;, &quot;fb_login&quot;: &quot; or login with Facebook&quot;, &quot;content_uuid&quot;: &quot;7e51320c-624e-11ea-bb53-1244d5f7c7c6&quot;, &quot;rss_feed&quot;: &quot;Comment Feed&quot;, &quot;type_comment&quot;: &quot;Type your comment here...&quot;, &quot;fb_logout&quot;: &quot;Logout&quot;, &quot;comment_required&quot;: &quot;Comment required&quot;, &quot;ugc_email_for_comments&quot;: true, &quot;ugc_allow_comments&quot;: true, &quot;type_captchas&quot;: &quot;Enter the word from the Image&quot;, &quot;view_more&quot;: &quot;View More&quot;, &quot;name_required&quot;: &quot;Name required&quot;, &quot;post_success&quot;: &quot;Comment successfully submitted. All comments are moderated and generally will be posted if they are on-topic and not abusive.&quot;, &quot;wrong_captchas&quot;: &quot;Wrong Captchas&quot;, &quot;email&quot;: &quot;Email&quot;, &quot;comments&quot;: &quot;Comments&quot;, &quot;info_text&quot;: &quot;All comments are moderated and generally will be posted if they are on-topic and not abusive.&quot;, &quot;chars_left&quot;: &quot;characters left&quot;, &quot;subject_required&quot;: &quot;Subject required&quot;, &quot;post_to_wall&quot;: &quot;Publish comment to your Wall&quot;, &quot;post_moderated&quot;: &quot;Comment successfully submitted. All comments are moderated and generally will be posted if they are on-topic and not abusive.&quot;, &quot;your_name&quot;: &quot;Your Name&quot;, &quot;subject&quot;: &quot;Type subject here...&quot;, &quot;email_required&quot;: &quot;Email required&quot;}, &quot;google_api_key&quot;: null, &quot;show_occ_paginator&quot;: false, &quot;media_support&quot;: {&quot;wh_sizes&quot;: [320, 480, 720, 1080, 1280, 1440, 1920], &quot;slots&quot;: [{&quot;display_type&quot;: &quot;gallery&quot;, &quot;media_count&quot;: 6, &quot;slot_ord&quot;: 0, &quot;slot_id&quot;: 33214, &quot;slot_uuid&quot;: &quot;5895e56f-15c9-4885-d71d-ddfc5cc74d28&quot;}]}}" id="_mp_page_content"></script>

  </body>
</html>
